Not able to add Project

Troels Heiredal's Avatar

Troels Heiredal

31 Dec, 2020 01:36 AM

Hi all,
Thank you for your amazing work. I might be the person with least understanding of coding to use Secretary, so I was hoping if someone could help me with this issue.

I've had the website set up and running fine, but now when I try to add a new project it doesn't show up. And in the project set-up I get a prompt that says:

"Uh-oh...
mysqli says: Field 'file' doesn't have a default value"

While also not being able to see any images I upload (see attached)
I can easily upload images to old projects, but not text groups.

Anyone knows an easy fix?

  1. Support Staff 1 Posted by Mikael on 11 Jan, 2021 11:36 PM

    Mikael's Avatar

    This might have something to do with the version of Secretary and PHP you are using. Can you tell me what you are running?

  2. 2 Posted by Troels Heiredal on 12 Jan, 2021 12:57 AM

    Troels Heiredal's Avatar

    Hi Mikael,

    Thank you for reaching out, I'm on Secretary 2.5 and PHP 7.4 (From One.com).

    The only other thing that I can think of, is that I switches computer a
    while back and this is the first time I'm trying to update the website
    since then. I have copied the Secretary package to my new computer (also a
    MacBook) but it's not placed in the same location. Tough I believe this
    should not effect it, right?

    Thank you for your time,
    Troels

  3. Support Staff 3 Posted by Mikael on 18 Mar, 2021 02:40 PM

    Mikael's Avatar

    Are you trying to run it locally on your laptop? There's always been some settings with PHP on local installations that don't do well with Secretary.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac